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1 Introduction

The GNU TEXMACS project aims to provide a free, polyvalent and user-friendly
scientific office suite, which can easily be interfaced with a wide range of external
mathematical software. The system can be downloaded from www.texmacs.org.
It should be noticed that TEXMACS has been developed from scratch in C++

and Scheme. In particular, the software does not rely on TEX or LATEX.

With respect to standard office suites such as Microsoft Word or Open Office,
we offer better support for mathematical typesetting, formula editing, and other
features useful for scientists. With respect to TEX/LATEX [Knu84, Lam94] and
its various front-ends, TEXMACS has the advantage of being completely wysiwyg

(what you see is what you get). Indeed, the development of our system was
initially motivated by the following reasons:

– An editor should allow the author to concentrate on what is written and
not on how it is written. In particular, editors should be as wysiwyg as
possible.

– With the advent of a wide variety of mathematical software, it should be
possible to make documents more active. One might wish to incorporate
computer algebra sessions and spreadsheets, for instance.

– Scientific editors should become more integrated, taking example on office
suits for non-scientific users. For instance, they should provide tools for
drawing technical pictures, making presentations from a laptop, anno-
tating texts, etc.

In this paper, we will present a quick survey of the traditional features of
TEXMACS and continue with more recent improvements and new features. The
next major release of TEXMACS 2.1 is planned for later this year.
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The core of TEXMACS consists of a free wysiwyg scientific text editor, which
includes a mathematical formula editor, the possibility to write structured texts,
and to extend the editor using personal style files or customizations of the user
interface. Advanced typesetting algorithms are used, which allow for the creation
of high quality documents.

Gradually, more and more features have been added to the software, thereby
moving towards our goal to provide a fully fledged scientific office suite. TEXMACS

currently offers an editor for graphical pictures, a presentation mode, a rudimen-
tary spreadsheet facility, integrated version control, etc. In addition, TEXMACS

has been interfaced to many external mathematical computation systems. These
interfaces can be used either in shell like sessions, inside spreadsheets, or on the
fly inside regular text.

Our main objectives for the next major version TEXMACS 2.1 are to increase
the portability of the software and to further improve the user experience.
For these reasons, we completely redesigned the graphical user interface (see
Figure 1), which is now based on Qt instead of Xwindows. Recent versions
of TEXMACS are available under Linux, MacOS and Windows. We took special
care at following standard user interface conventions for each of these operating
systems (regarding keyboard shortcuts, for instance). The existing LATEX con-
verters were also greatly improved and we now provide a native converter to Pdf.
We finally improved the font support and the internationalization of TEXMACS.

Figure 1. The new graphical user interface of TEXMACS under MacOS.

2 TEXMACS as a structured text editor

The backbone of TEXMACS is a wysiwyg structured text editor. The user interface
is redundant by design, so as to make the software suitable for users with diverse
backgrounds. For instance, in order to create a new section, the user has the
following options:

1. Use the Insert→Section→Section menu item.
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2. In the second icon bar, click on the icon, followed by a click on Section.

3. As in LATEX, type \ S E C T I O N followed by ©.

4. Use the keyboard shortcut Alter-1 .

In a similar way as in LATEX, authors are invited to concentrate on intent rather
than presentation. Nevertheless, most tags have a sufficiently distinctive pre-
sentation for making the structure apparent from the mere rendering of the
document.

All documents are internally represented and manipulated as trees. The
structure of the documentation is made more visible to the user by putting
non intrusive boxes around all tags which contain the cursor. The innermost
tag is called the current focus and is highlighted using a special color. Various
editing operations allow the user to directly operate on the structure of the doc-
ument. For instance, if the current focus is a section title, then there are actions
for changing it into a subsection title, to jump to the next and the previous
section, to toggle the numbering, or to get contextual help on the section tag.

An analogue of the “LATEX source code” is available in TEXMACS using Doc-

ument→Source→Edit source tree. However, from our standpoint, there is no
real concept of the “source code”. In reality, documents are trees, which can
be rendered in different ways so as to make certain tags more or less explicit.
In particular, the presentation of the “source code” can be customized using
Document→Source→Preferences. Furthermore, we consider x

√
to be just as

good (and arguably even better) a “source code” as \sqrt{x}.
TEXMACS also allows the user to create new style sheets or to modify the

definitions of existing presentation macros. In recent versions, this kind of cus-
tomizations have been made even easier: we both provide simplified widgets for
editing macros and the possibility to jump directly to the definition of the macro
corresponding to the current focus.

3 Mathematical formulas

Special care has been taken so as to make the input of mathematical formulas
particularly efficient. First of all, we designed a special input method which
allows users to enter most mathematical symbols are obtained using a small set
of basic rules:

– Characters which are naturally obtained as “superpositions” or “concate-
nations” of symbols on your keyboard are entered in a straightforward
way. For instance, - > yields →, < = yields 6, + - yields ± and < <

yields ≪.

– The “variant” key å may be used in order to obtain variants of a given
symbol or keyboard shortcut. For instance, < = å yields ≤, < = å å å yields
⇐, < å yields ≺ and < | å yields ⊳. All Greek letters can be obtained
as variants of the Roman ones: A å yields α, L å yields λ and so on.
Sometimes, additional variants are available: B å å yields ♭ and E å å yields
the mathematical constant e.
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– The / and @ keys are used for obtaining negations and symbols inside
other symbols. For instance, < = / yields 
 and @ + yields ⊕. More elab-
orated examples are @ å + and < å = å / å , which yield ⊞ resp. �.

Efficient shortcuts are also available for most mathematical constructs: %F starts
a fraction, Alter-S a square root, _ a subscript, ^ a superscript, etc. Being
faithful to the principle of redundancy, these actions can also be performed
through the menus, the icons, or via LATEX equivalents.

Inside a mathematical formula, the cursor keys allow you to move around in a
graphically intuitive way. In particular, when done with a particular subformula,
it usually suffices to press the right arrow key � in order to return to the main
formula.

Wysiwyg editors are especially interesting for more complex formulas. For
instance, it is easy to insert new rows and columns inside a matrix, or to copy
and paste submatrices (and not only rows).

Another particular feature of TEXMACS is that formulas carry more semantics
than in LATEX, when entered appropriately. For instance, “invisible” multiplica-
tion (as in x y) should be entered explicitly using * , whereas function application
(as in sin x) should be entered using Space.

Recent versions of TEXMACS integrate a parser for mathematical formulas and
a syntax checker. When activating “semantic editing” from the icon menu,
the focus box indicates the arguments of mathematical operators and its color
changes to red whenever a formula is syntactically incorrect. The mathematical
formula parser is based on a fixed grammar which works on a wide variety of
mathematical texts. Nevertheless, the user can explicitly modify binding forces
when needed and define specific notations using the standard macro mechanism.
We refer to [Hoe11] for more details.

4 Interfaces with external software

TEXMACS has been interfaced with many external systems [Gro01]. In partic-
ular, we have interfaces for the computer algebra systems Axiom, Macaulay2,
Maple, Mathemagix, Mathematica, Maxima, Pari, Reduce, Sage, etc.
We also have interfaces for other mathematical software, such as Octave, R,
Scilab, etc.

The traditional way to use “plug-ins” is through “shell sessions”:

Maxima 5.9.0 http://maxima.sourceforge.net

[...]

(%i1) diff (x^x^x^x, x);

(%o1) xx
x
x

(xx
x

log (x) (xx log (x) (log (x)+ 1)+xx−1) +xx
x
−1)

(%i2) integrate (%o1, x);

(%o2) ee
exlog (x)

log (x)log (x)

TEXMACS also supports two-dimensional input, through toggling of Focus→
Input options→Mathematical input:
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(%i3)

∣

∣

∣

∣

x+ y y

x− y2 y+ z

∣

∣

∣

∣

(%o3) (y+ x) (z+ y)− y (x− y2)

The semantics of the mathematical output depends on the plug-in. For well-
designed plug-ins, it is possible to copy and paste formulas between different
systems.

Recent versions of TEXMACS feature several additional ways to use external
software in a more implicit way. For instance, after selecting Maxima as
the “scripting language” in Document→Scripts, one may evaluate a mathemat-
ical formula such as 1+2+3 by putting the cursor inside it and pressing Ctrl-©.
For the preparation of interactive class material, one may also insert ‘‘exe-
cutable switches” such as Maxima

∑

k=1
100

k2 . We may toggle the states of such

tags between evaluated and unevaluated. Table 1 finally shows an example of
a Mathemagix spreadsheet inside TEXMACS.

x
x

=derive(a1, x)
=derive(a2, x)
=derive(a3, x)
=derive(a4, x)

=derive(a5, x)

!
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2 +

4
)
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1
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2 +
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x
3

)
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log(x)5 + 5 log(x)4 + 10
(

1

x

+ 1
)

log(x)3 +
(

30

x

−
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x
2
+

10
)

log(x)2+
(

5+
30

x

−

5

x
2
+

10

x
3

)

log(x)+1+
10

x

+
5

x
2
−

6

x
4

)

x
x

Table 1. Computation of successive derivatives in a spreadsheet.

5 Towards a scientific office suite

We have seen that TEXMACS integrates a structured text editor, a formula editor,
a spreadsheet facility and many interfaces to external programs. Let us describe
a few other tools that are available nowadays inside our system, which make
TEXMACS a fairly complete scientific office suite.

5.1 Presentation mode

A wysiwyg editor such as TEXMACS is particularly useful for preparing laptop
presentations. For this, it suffices to select beamer as the document style in
the Document→Style menu. In addition, several standard themes can be used.
Presentations are organized as successions of “screens”.

Special markup is provided for showing and hiding content in specified orders.
For instance, the “unroll” tag allows item lists to be unrolled progressively. There
is also support for general “overlays”, where the user has full control over the
order in which content appears and disappears on specified ranges of overlays.
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The Insert→Animation menu allows for the insertion of animated content.
For the moment, only simple animations are implemented, but more elaborate
graphical effects and artwork are planned for future versions, as well as support
for embedded videos.

5.2 Technical pictures

Existing pictures can be embedded inside a document using Insert→Image→
Insert image or Insert→Image→Link image. In addition, TEXMACS includes
a native editor for drawing simple technical pictures. One advantage of this
integrated drawing tool is that it is easy to include mathematical formulas or
other TEXMACS markup inside the picture. One may use Insert→Image→Draw

image to start a new drawing and Insert→Image→Draw over selection to draw
a picture on top of the current selection (typically an external picture, or a math-
ematical formula). Currently, TEXMACS implements the most basic primitives
for drawing vector graphics. We have plans to extend the TEXMACS macro mech-
anism to graphics and to offer full support for the SVG standard.

31

3

2

1 g(x) = (3+ x)/4

f(x)= 1− 1−x2
√

0

Figure 2. Toy example of a technical picture created with the drawing tool.

5.3 Version control

TEXMACS comes with an efficient tool for computing and visualizing “structured
differences” between two versions of a document. The default way to visualize
changes is to show the old and new versions side by side in different colors.
Authors may quickly go trough the changes introduced by a coauthor and select
which versions they prefer. TEXMACS also integrates support for external ver-
sioning software. For the moment, we only provide an interface for Svn, but it
would be easy to add interfaces for other systems.

6 Compatibility with other formats

Unfortunately, TEXMACS is not yet as wide-spread as LATEX. For the sake of
backward compatibility, TEXMACS provides high quality converters from and to
LATEX. However, these converters cannot be perfect for several reasons.
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The main reason is that LATEX is not a format, like Html, but rather a pro-
gramming language. In particular, the only program which parses all LATEX files
correctly is LATEX itself. Since TEXMACS is not a LATEX front-end, it follows that
we can only ensure correct conversions for a (quite large) sublanguage of LATEX.

The other main reason is that TEXMACS has a more powerful typesetting
engine than LATEX and that it provides several extensions (like a graphical
editor or animations) which are not available in LATEX. Therefore, a conversion
to LATEX may downgrade your document, both in typesetting quality and in
structure. For instance, TEXMACS pictures are exported as postscript images, so
their structure is lost.

Nevertheless, during recent years, we have invested a lot of energy in making
the LATEX converters as good as possible, in both directions. In particular, we
support the most frequently used LATEX styles. The behaviour of the converters
can be fine-tuned for specific needs via the user preferences. For instance, should
macros be expanded or not during conversions? Are preambles allowed to contain
additional macro definitions? Etc.

An interesting recent addition is the possibility to use the converters in
a “conservative” fashion [HP14]. For instance, assume that Alice writes a doc-
ument in LATEX and sends it to Bob. Bob opens the document in TEXMACS,
makes a few modifications and exports the document back to LATEX. Conser-
vative converters have the property that the exported document will be almost
the same as the Alice’s original version: ideally speaking, only Bob’s changes
will really be exported.

Besides LATEX, reasonably good converters for Html and MathML have
also been implemented, again in both directions. For instance, the TEXMACS

website is entirely generated from TEXMACS documents.
Last but not least, TEXMACS is wysiwyg, which means that TEXMACS tradi-

tionally features a lossless converter to Postscript. More recently, a native
converter to Pdf has also been implemented. This new converter includes an
improved support for images, fonts and certain types of graphics. In particular,
the quality of Pdf documents with oriental languages is much better nowadays.

7 Customization

TEXMACS can be customized in many ways. Besides the possibility to write
your own style files for the presentation of documents, it is also possible to
customize the behaviour of the editor, or to write new plug-ins for external
software. We will briefly give a few examples below. Questions can be asked on
our mailing lists:

http://www.texmacs.org/tmweb/home/ml.en.html

7.1 User-defined macros

The user may define new typesetting constructs or customize the rendering of
the standard styles using a special macro language. For instance, one may define
a macro cd for square commutative diagrams using
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〈assign|cd |〈macro|A|B |C |D |
A → B

↓ ↓
C → D

〉〉

This macro may then be used by typing \ C D © , as in

A⊕B → C

↓ ↓
D → E ⊗F

For more information, we refer to Help→Manual→Writing your own style files and
Help→Reference guide.

7.2 Customizing the interface and Scheme extensions

Following the example of GNU Emacs, the user interface and most of the editing
functions of TEXMACS are written in Scheme, a high level “extension language”.
This makes it possible for the user to customize the behaviour of TEXMACS and
write extensions to the editor. Simple customizations can be put in the file my-
init-texmacs.scm of the .TeXmacs/progs subdirectory of your home directory.
For instance, assume that this file contains the following code:

(kbd-map

(:mode in-text?)

("T h ." (make ’theorem))

("D e f ." (make ’definition)))

Then the keyboard shortcuts çT H . and çD E F . can be used inside text mode in
order to insert a theorem resp. a definition. In a similar way, you may customize
the menus, or add more complex extensions to the editor. For more details, we
refer to Help→Scheme extensions.
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